WordPress 4.0 之前的版本将失去安全更新

WordPress 安全团队宣布在2022年12月1日之后,将不再提供 3.7 至 4.0 版本的安全更新,WordPress 3.7 版本是在 2013 年发布的,当时 WordPress 在这个版本引入了后台自动更新,然后 3.8 版本重新设计了后台。

WordPress 官网仅提供最新版本的 WordPress 下载,但安全团队一直坚持向后移植安全修复程序的做法,这样使用旧版本 WordPress 的站点也不会有安全问题的困扰,这是一种非常负责任的做法。

3.7 - 4.0 已经非常少人在用

目前这些向后移至安全更新支持所有支持自动更新的 WordPress 版本,即从 3.7 版本开始。

其中 WordPress 3.7 - 4.0 版本已经很少人使用了,据官方的数据统计,只有不到 1% 的人在用,超过一半的 WordPress 网站都使用最新版本 6.0+ (54.3%),所以提供这些安全更新所涉及的工作量已经远远超过得到好处了。

将安全更新向后移植到旧版本的 WordPress 需要大量时间,这个工作量还随着每个新版本的发布而不断增加,这就意味着 WordPress 安全团队的大部分时间花费在为这些使用量非常少的旧版本的 WordPress 准备向后移植程序。

所以通过放弃对这些旧版本的支持,安全团队可以有更多时间专注于当前的需求,从而使得新版本的 WordPress 变得更加安全。

因为使用 3.7 - 4.0 版本的站点只有 1%,所以之后超过 99% 的使用旧版本的网站仍然可以获得安全更新。

如何实施这一过程

在接下来的三个月中,3.7 - 4.0 版本将还会收到安全更新,并且还会在仪表板中显示一个不可关闭的通知,用来建议用户升级到最新版本,因为他们的网站将不再收到安全更新。


©我爱水煮鱼,本站推荐使用的主机:阿里云,国外主机建议使用BlueHost

本站长期承接 WordPress 优化建站业务,请联系微信:「chenduopapa」。

标签:

热门文章